WordPress中的JS和CSS文件引入时带有ver参数,在浏览器中审查元素或者 F12 查看其引入的文件,就如图中一样,文件的末尾会带有一个这样的参数,这样打开一次不需要每次加载,但是修改style.css文件不生效,带有这个参数的作用就会让浏览器加载缓存的JS和CSS文件,而你修改了样式之后它还是不会生效。

因此,在修改CSS文件或JS文件时,可以暂时关掉这个Ver参数。

修改的方法:在根目录里面wp-includes 目录下的 version.php 文件找到:

$wp_version = '5.3.1';

把这个wp_version参数值改为null即可:

$wp_version = null;

不过直接去掉可能导致有一些插件的识别有问题,大家可以在原来的版本号加1。

$wp_version = '5.3.2';

这样再次打开网站时,浏览器会再次更新缓冲。

喵站星球 https://bbs.liulinblog.com(这里满足你一切资源需求)

博主花了大量金钱和精力,整理了淘宝,拼多多,公众号中绝大多数的付费资源 满足你娱乐工作学习各方面需求,有发帖求助平台,需要什么论坛里发帖......

注册论坛需购买邀请码: https://dwz.cn/qR44lE1Q (持续涨价)

发表评论

后才能评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据